Jump to content


  • Announcements

    • AutoShopOwner

      Advertising & Promoting Your Company On AutoShopOwner - Information   02/25/2017

      This message is only shown to FREE members and goes away after subscribing to a paid membership. If you are joining AutoShopOwner to promote your business, service, or product to this community of auto shop owners, please subscribe to a Sponsor Member Annual Package before doing so. With the correct membership, you will have the ability to post about your company in your posts and forum signature.

      You can upgrade your existing membership here.

      All marketing attempts to this community without proper membership level and/or approval by staff, will be considered spam, result in topic/post removal, and a warning, which can lead up to the banning of your membership, company and/or product on all pages of AutoShopOwner.

      Thank you for your support.
Gonzo

Article: They Come In Threes - - - Good And Bad, It Always Seems To Come In Threes

Recommended Posts

They Come In Threes

Good things, bad things, they just can’t show up all by themselves; not just once, hardly ever twice, nope… always in threes. At least it seems that way. Why, I don’t know… it just does, I guess. Whether it’s a great day of easy going jobs at the repair shop, or something at the house, you can almost count on the threes. It’s like there’s some sort of buddy system going on with all this chaos.

Take the other day when I got my big mower out of the garage. I always make it a habit to check the tire pressure, oil and gas before I start mowing. Sure enough, I’m low on the go juice, well… might as well fill it up, oh wait minute… that tire…it’s not low… it’s flat! Oh geez… Ok, gotta take care of that too. Oh, no… what’s this? It’s a broken stabilizer bar for the mowing deck. Now how did that happen? Sheared the bolt clean off. I’ll have to weld that back together before I go anywhere. As usual I had a few choice “words” to say about the whole thing, which brought the wife out to see what all the commotion was about. She just shook her head as she walked back inside.

After I finished mowing and put the tractor away, I couldn’t help but notice a strong fuel smell coming from it. Oh geez, the gas cap is missing. Crud, I didn’t screw it back on tight; now I’ve got to take that long slow walk through the yard trying to find the missing cap. (More grumbling and choice words again). I found the cap lying on the ground just a few feet from where I filled up. (Lucky)

Anyway, that ended the debacle at the house. It’s Monday morning again, and I’m back at the office. Cars were already lined up outside. I was expecting a pretty good turn out this morning. Based on all the calls I received the week before, I was counting on a pretty productive day. The very first job was a no start on a 2006 Chevy truck with an 8.1 liter. The scanner was my first choice, since I could hear the fuel pump hum as I turned the key. The Tech II beeps were loud and clear in the still morning air as I stood out in the parking lot gathering the information. I went straight to the service codes section … “No Codes Present”.

I thought to myself, “What in the world is going on here? No codes?”

I cranked the engine again… nothing. Ok, now what!? Back up a couple of screens to the data section and crank the engine again, this time watching the cam and crank signals. Neither budged. It’s probably a bad crank or cam sensor… or both. Might as well run back in and grab the scope to check the wave patterns, since this truck’s computer seems to think everything is just hunky-dory.

I’ll bet if this PCM could talk right now it would probably be saying something like, “Hey, what’s your problem? Everything is fine here; me (the PCM) and all the sensors are just sitting around have a good time. Don’t see what all the fuss is about.” (Stupid computer…! Doesn’t even know when it should be telling me something important. A service code would be nice right about now. But, no… that would be too easy.) Well, it did end up being the cam and crank sensor, even though that pesky PCM didn’t seem to care.

It didn’t stop there. Later, another job came in with an A/C problem. This one was a 2008 Acura. The pressure levels were good enough to kick the compressor on, but no clutch engagement. I’ll try talking to this car with a scanner. Oh, would ya look at that… it says, “Everything is fine, no codes here. Don’t know what your problem is, we’re all having a great time under the hood.” (A few choice words seemed appropriate right about now.)

This is crazy; two jobs in a row where the computer is supposed to be helping me diagnose the problem are both saying there is no problem? A little more checking and a few more choice words I had it solved. (Had to go through the instrument control module that’s where all the A/C information was at. The prints referred to the instrument cluster as the “Instrument Control Module”. As if checking for an A/C signal by way of the cluster wasn't confusing enough already, you had to go and rename the dang thing.) It turned out to be bad compressor after all of that. Still no codes, though.

I thought I was done, done with all these weird problems… but no… they come in threes don’t they? Now it’s this 1998 Chevy van’s turn. This van had the propensity to shift all the way to high gear, before it even passed 30mph. It wasn’t a harsh shift, it wasn’t a slip… it just shifted super-fast. My buddy Jeff, over at the transmission shop checked it out earlier, and determined that it was an electrical problem. This didn’t sound easy to diagnose… but like Jeff said, “If it was easy, I wouldn’t be bringing it to you.” (Remind me to thank you later, Jeff.)

The first thing I did after a test drive was scan it. Oh please…not again… are you kidding me? It’s another no codes present scenario. I swear I heard a little snicker from this van’s computer.

As if it was saying, “Don’t know what to tell ya, we’re all fine in here.” (You know there are times I think those little electrons are just laughing at me.) At this point I’m thinking an internal computer glitch, but I better play it safe and try to recalibrate, or at least see if there’s an update for the PCM. There was, so I downloaded the info into the van’s PCM.

Another drive test… no change. Codes? … Seriously you thought there would be codes? NOT! After removing the PCM it wasn’t hard to spot the water damage inside the unit. After installing the new PCM a code popped up. Wow… a code? A real code! Hmm, transmission TCC solenoid. The Tech II couldn’t activate the solenoid either. I better call Jeff. By now we both had enough of this job, and after a brand new (not reman’d) PCM was installed, neither one of us were thinking it could be a bad computer… must be the solenoid. But, it wasn’t the TCC solenoid; it was the brand new computer. (Choice words again… they seem to be popping up more frequently, have ya noticed?). Another computer, another reprogram, (Third time programming the same van, by the way) … finally… everything is working.

What should I expect next? Maybe some more brand new “bad” parts? Maybe it’s Jeff’s turn for wacky repairs. Maybe … it’s another lawnmower fiasco? Maybe I should start triple checking things instead of double checking. Who knows? But, like my buddy Jeff tells me, “Whatever it is… good or bad. They come in threes you know.”

 

Click here to view the article

Share this post


Link to post
Share on other sites





×